CURSO: CURSO SUPERIOR DE TECNOLOGIA EM TELEMÁTICA PERÍODO: P1 TURMA: N

PROFESSOR: CÉSAR ROCHA VASCONCELOS SEMESTRE LETIVO 2009.2

LISTA DE EXERCÍCIOS 03 – ESTRUTURAS DE DECISÃO E REPETIÇÃO

1. Em que consiste a estrutura seqüencial? 2. Determine os valore finais de A, B e C após a execução do trecho do algoritmo abaixo:

3. A ordem das atribuições é importante? A¬B e C‹A tem o mesmo efeito de C‹A e A‹B ? 4. Em quais dos seguintes pares à ordem dos comandos é importante?

5. Escreva um algoritmo que leia duas variáveis inteiras, troque o conteúdo entre elas e as imprima (antes e depois da troca).

6. Escreva um algoritmo que leia um número inteiro positivo e exiba o dobro do mesmo.

7. Escreva um algoritmo para calcular e exibir a média ponderada de duas notas dadas ( nota1 = peso 6 e nota2 = peso 4 )

8. Escreva um algoritmo para calcular e exibir o comprimento de uma circunferência, sendo fornecido para o algoritmo como entrada o valor de seu raio. Fórmula: C=2pR

9. Escreva um algoritmo para ler o nome e o sobrenome de uma pessoa e escrevê-los na seguinte forma: sobrenome seguido por uma vírgula e pelo nome. Ex:

10. Qual a utilidade da estrutura de decisão? 1. Qual a diferença entre a estrutura de decisão simples e a composta? 12. Escreva um algoritmo que leia dois números e exiba-os em ordem crescente. 13. Escreva um algoritmo para ler um número e determinar se ele é maior, igual ou menor que zero.

14. Faça um algoritmo que, dadas três notas de um aluno e seu nome completo, exiba o nome, determine e exiba a sua média final e o seu conceito, sabendo-se que:

§ a média final é calculada pela média aritmética das 3 notas;

§ o conceito é determinado de com base na tabela a seguir:

15. O Botafogo Futebol Clube deseja aumentar o salário de seus jogadores. O reajuste deve obedecer a seguinte tabela:

Escrever um algoritmo que leia o nome e o salário atual de um jogador, e exiba o nome, o salário atual e o novo salário reajustado.

16. Observe o algoritmo abaixo:

Algoritmo Nó-No-Juízo: var //Declaração das variáveis L1, L2, L3 : logico inicio //deve-se passar como entrada apenas verdadeiro ou falso Escreva(“Entre com o valor L1: ”) Leia(L1) Escreva(“Entre com o valor L2: ”) Leia(L2) Escreva(“Entre com o valor L3: ”) Leia(L3)

Então

Se (L1 = VERDADEIRO)

Escreva (“A”)

Senão

Então

Se (L1 = FALSO)

Então Escreva (“B”)
Senão
Escreva (“C”)
Escreva (“D”)
Fim-se
Fim-se
Fim-se

Se (L3 = VERDADEIRO) Escreva (“E”)

Fimalgoritmo

Agora, responda as seguintes questões:

a. Se forem lidos, nesta ordem, V, V e F, o que será escrito pelo algoritmo? b. Se forem lidos, nesta ordem, F, V e F, o que será escrito pelo algoritmo? c. Se forem lidos, nesta ordem, F, V e V, o que será escrito pelo algoritmo? d. Que valores deveriam ser lidos para que fosse escrito apenas "E"?

20. Faça um algoritmo que gere a seguinte série: 10, 20, 30, 40,, 990, 1000.

17. Qual a utilidade da estrutura de repetição? 18. Em que consiste o controle de repetições por contador? 19. Em que consiste o controle de repetições por flag? 21. Faça um algoritmo para gerar e exibir os números inteiros de 100 até 1, decrescendo de 1 em 1. 2. Faça um algoritmo que mostre todos os números inteiros de 1 a 50. 23. Faça um algoritmo que mostre todos os números inteiros pares de 2 a 100.

24. Faça um algoritmo que leia uma lista de N números e mostre a soma de todos os números desta lista.

25. (Para profissionais!) Escreva um algoritmo que leia um conjunto de 100 números inteiros positivos e determine o maior deles.

26. Faça um algoritmo que leia a altura de um grupo de 20 pessoas, calcule e exiba: § a maior altura do grupo;

§ a altura média;

§ o número de pessoas com altura superior a 1.60 metros.

27. (Para profissionais!) Foi feita uma pesquisa de audiência de canal de TV em várias casas de uma certa cidade, num determinado dia. Para cada casa visitada, foi fornecido o número do canal (5, 7, 10 ou 12) e o número de pessoas que o estavam assistindo naquela casa. Fazer um algoritmo que:

§ leia um número indeterminado de dados, sendo que a flag de parada corresponde ao canal igual a 0 (zero);

§ calcule e escreva a porcentagem de audiência de cada emissora.

28. Faça um algoritmo que leia uma lista de letras. A flag será determinada pela letra Z. Ao final, o algoritmo deve mostrar a quantidade de vogais lidas nesta lista.

29. Escreva um algoritmo que leia um conjunto de números inteiros positivos e determine o menor deles. A leitura do valor 0 (zero) indica o fim dos dados (flag).

30. Faça um algoritmo que, para um número indeterminado de pessoas:

§ leia a idade de cada pessoa, sendo que a leitura da idade 0 (zero) indica o fim dos dados (flag) e não deve ser considerada;

§ calcule e escreva o número de pessoas;

§ calcule e escreva a idade média do grupo;

§ calcule e escreva a menor e a maior idade;

Comentários