Lógica de Programação Seleção

Eduardo Henrique

Conceito

Também chamada de “Seleção”, é uma estrutura de decisão usada para desviar a execução do algoritmo, dependo da veracidade de uma condição (expressão lógica)

A estrutura condicional pode ser Simples ou Composta

Eduardo Henrique2

Condicional

Explicação

Só é executada, se a expressão lógica tiver resultado verdadeiro

Sintaxe

Se <Expressao_Logica> Entao

// Sequência de instruções FimSe

Eduardo Henrique3

Condicional Simples

Exemplo

// Sexo é variável literal

SeSexo = “M” Entao

Escreva(“Masculino”) FimSe

Eduardo Henrique4

Condicional Simples

Faça um algoritmo que leia uma variável inteira e calcule se é um número par.

Caso seja par imprima a mensagem: “Número PAR”

Eduardo Henrique5

Exercício

Explicação

Se a expressão lógica for verdadeira executa a primeira parte da condicional, caso contrário, a segunda parte da seleção será executada

Sintaxe

Se <Expressao_Logica> Entao

// Instruções para o valor Verdadeiro

Senao

// Instruções para o valor Falso FimSe

Eduardo Henrique6

Condicional Composta

Exemplo

SeSexo = “M” Entao

Escreva(“Masculino”)

Senao

Escreva(“Feminino”) FimSe

Eduardo Henrique7

Condicional Composta

Faça um algoritmo que leia uma variável inteira e calcule se é um número par.

Caso seja par imprima a mensagem:

“Número PAR”

Caso seja impar escrever: “Número Impar”

Eduardo Henrique8

Exercício

Explicação

É tão somente aplicação de condicionais uma após outra

Sintaxe

Se <Expressao_Logica> Entao

Senao

// Instruções

Se <Expressao_Logica> Entao

FimSe FimSe

Eduardo Henrique9

Condicionais Aninhadas

Exemplo

Se(Numero > 0) Entao

Escreva (“Número Positivo”)

Senao

Se(Numero < 0) Entao

Escreva (“Número Negativo”)

Senao

Escreva (“Número Zero”)

FimSe FimSe

Eduardo Henrique10

Condicionais Aninhadas

Faça um algoritmo para formular uma enquete a respeito do grau de dificuldade da do conteúdo “Algoritmo”. É preciso ler uma variável numérica com os valores de 1 a 5, onde 1 representa “Muito fácil” e 5 “Muito difícil”. E, imprimir a escolha por extenso.

Use o “Se” aninhado.

Eduardo Henrique11

Exercício

Caso

É uma alternativa à condicional aninhada

Sintaxe

Escolha <Variavel>

Caso Valor_1

// Instruções para Valor_1

Caso Valor_2

// Instruções para Valor_2

[OutroCaso]

// Instruções para o caso padrão FimEscolha

Eduardo Henrique12

Caso

Exemplo

Escolha Escolaridade

Caso “Médio”

Escreva (“Nível Médio”)

Caso “Superior”

Escreva (“Nível Superior”)

OutroCaso “Especialista”

Escreva (“Nível Especialista”) FimEscolha

Eduardo Henrique13

Caso

Refaça o exercício anterior utilizando “Caso” Eduardo Henrique14

Exercício

Comentários