Aula-Algoritmo-estruturas de repetição

Aula-Algoritmo-estruturas de repetição

Algorítmose Programação I

Professora Cleusa Fevereiro/2011

Nestecapítulo

• Estruturasde repetição.

Repita Para

Enquanto

Introdução

Permite que tarefas individuais sejam repetidas um número determinado de vezes ou tantas vezes quantas uma condição lógicapermita.

Conhecida porloopingou laço.

Exemplo:

Vou atirar pedras na vidraça atéquebrá-las.

Enquanto tiver vida ou dinheiro vou desfrutar da vida.

Estrutura de repetição

Sintaxe: Enquanto condição faça

Comando 1 Comando 2 . . . Comando n Fim Enquanto

Estrutura de repetição-com teste no início ENQUANTO

Onde:

Enquanto..faça

(palavras reservadas do algorítmo)

Condição

(expressão lógica a ser analisada)

Comandos ( instruções que serão repetidas)

Fim Enquanto

(palavra reservada do algorítmo)

Estrutura de repetição-com teste no início Sintaxe:

Enquanto ( expressao logica ) faça acao1; acao2; acao3; Fim enquanto; inicio caracter:nome; inteiro: contador; contador 1;

escreva ( “Informe o seu nome”) faça

; contador contador + 1; fim enquanto; fim;

// Início do algoritmo // Declaração de variável nome

// Declaração de variável contador

//Inicializandoa variável contador

// Exibindo a mensagem na tela

// Armazena o nome informado na variável nome

// Início do laço

// Imprimindo o conteúdo da variável nome na tela

// Incrementando o contador em uma unidade

// Fim do laço

// Fim do algoritmo

Estrutura de repetição-com teste noinício EXEMPLO - ENQUANTO inicio real: num,somar; soma 0; escreva ( “Informe o numero a ser somado”) faça soma soma+num; escreva ( “Informe o número a ser somado”)

; fim enquanto; escreva ( “A soma vale;”soma)

Estrutura de repetição–com variável de controle

Sintaxe: Para variável de valor inicial até valor final passo n faça ação 1; ação 2; ação n; fimpara

Para..de...até...faça (palavras reservadasdo algorítmo) Passo

(palavra reservadado algorítmo, que indica qualéa avariação do contador ) N (número que indica o incremento ou decremento do contador) variável (Variável numérica que seráutilizada como contador) valor inicial (Valor de partida do contador) valor Final (Valor de parada do contador-interrupção) Fim Para (palavra reservadado algorítmo)

Inicio inteiro: NUMERO; para NUMERO de 1 até 10 passo 2 faça escreva ( “Este e o numero:”,NUMERO)

; fim para; fim;

// Início do laço // Fim do laço

Estrutura de repetição –PARA EXEMPLO

Estrutura de repetição-com teste no fim

Sintaxe: repita acao1; acao2; acao3; ate (expressão lógica ) inicio inteiro: VALOR; VALOR 0; repita VALOR VALOR + 1; escreva VALOR ateVALOR < 100; fim;

Repita EXEMPLO

Comentários