Estruturas de Repetição

Estruturas de Repetição

Lógica de Programação Repetição

Eduardo Henrique

Conceito

Permite executar uma instrução ou um conjunto de instruções várias vezes

Sub-divisão

Enquanto Para

Repita

Eduardo Henrique 2

Estruturas de Repetição

Conceito

Executa enquanto expressão lógica for verdadeiro

Sintaxe

Enquanto ExpressaoLogica Faca

//Conjunto de Instruções

FimEnquanto

Obs: Não esquecer de manipular variável da ExpressaoLogica

Eduardo Henrique 3

Enquanto

Exemplo

// I é uma variável Inteira

Enquanto I <= 5 Faca

Escreval(“Número ”, I) // Manipulação da variável

// da condição de parada

I <- I + 1 FimEnquanto

Eduardo Henrique 4

Enquanto

Resultado

Número 1

Número 2

Número 3

Número 4 Número 5

Eduardo Henrique 5

Enquanto

Faça um algoritmo que imprima a soma dos dez primeiros números inteiros positivos.

Faça um algoritmo que calcule a média aritmética dos 100 primeiros números inteiros pares.

Eduardo Henrique 6

Enquanto - Exercício

Conceito

Executa até atingir o limite da Expressao Lógica

Sintaxe

Para ExpressaoLogica Passo Valor Faca

//Conjunto de Instruções

FimPara

Obs: Caso o valor do passo seja omitida será usado o padrão “1”

Eduardo Henrique 7

Para

Exemplo 1

// I é uma variável Inteira

Para I <- 1 Ate 5 Faca

Escreval(“Número ”, I) FimPara

Eduardo Henrique 8

Para

Resultado do Exemplo 1

Número 1

Número 2

Número 3

Número 4 Número 5

Eduardo Henrique 9

Para

Exemplo 2

// I é uma variável Inteira

Para I <- 1 Ate 5 Passo 2 Faca

Escreval(“Número ”, I) FimPara

Eduardo Henrique 10

Para

Resultado

Número 1

Número 3 Número 5

Eduardo Henrique 1

Para

Faça os exercícios apresentados no “Enquanto” usando o “Para”.

Faça um algoritmo para calcular e imprimir a série Fibonacci até do primeiro ao décimo termo. A série tem a seguinte forma: 1,1,2,3,5,8,13,21,34

Eduardo Henrique 12

Para - Exercício

Conceito

Executar instruções enquanto expressão lógica for falsa. Garante pelo menos uma iteração

Sintaxe

Repita

//Conjunto de Instruções Ate ExpressaoLogica

Eduardo Henrique 13

Repita

Exemplo

// I é uma variável Inteira

Repita

Escreval(“Número ”, I)

I <- I + 1 Ate I > 5

Eduardo Henrique 14

Repita

Resultado

Número 1

Número 2

Número 3

Número 4 Número 5

Eduardo Henrique 15

Repita

Faça os exercícios apresentados no “Enquanto” usando o “Repita”.

Elabore um algoritmo que imprima o fatorial de N. N será informado.

Eduardo Henrique 16

Repita - Exercício

Comentários